site
header
Rendez-vous sur Arrakis
Le site perso d'un hacker libriste curieux crêpophile et étourdi

Mise à jour d'owi : OpenBSD Wifi manager

Je met à jour le gestionnaire de connexion wiFi pour OpenBSD après y avoir ajouté quelques éléments et simplifié le code :

aperçu de owi

le 17/06/2017 à 10:01:42, fredg a dit :

Super, merci :)

le 17/06/2017 à 10:59:07, arpinux a dit :

bientôt ... bientôt :P

le 17/06/2017 à 12:30:51, Kobol a dit :

J ai décidé de me mettre aux vers. C'est la meilleure alternative.

le 17/06/2017 à 12:41:53, thuban a dit :

Je réalise que les noms des réseaux chez moi sont assez marrants ^^

le 22/06/2017 à 14:22:15, r00tBSD a dit :

J'aime le travail bien fait ! Merci pour vos contributions !

le 17/12/2017 à 21:54:42, NewBSD a dit :

Tres bonne initiative cependant ne fonctionne pas chez moi dommage, je vais continuer avec a l'ancienne pour l'instant ;)

# pkg_add python-tkinter    
 quirks-2.367 signed on 2017-10-03T11:21:28Z
 Ambiguous: choose package for python-tkinter
 a       0: <None>
         1: python-tkinter-2.7.14
         2: python-tkinter-3.6.2
 Your choice: 2
 python-tkinter-3.6.2: ok
 # vi /etc/doas.conf
 $ pwd
 /home/****/Downloads/owi
 $ doas owi
 doas (****@*****.*****.localhost) password: 
 doas: owi: command not found
 

Une petite idee d'ou peut venir le probleme?

le 18/12/2017 à 08:21:24, thuban a dit :

Owi n'est pas dans ton path

Essaie plutôt ainsi s'il n'est pas dans /usr/local/bin :

doas ./owi

le 21/12/2017 à 20:00:53, NewBSD a dit :

Je l'ai mis dans le path la premiere fois et j'ai eu la meme erreur.
J'ai naturellement essaier

doas ./owi

directement depuis l'archive decompresser, mais rien a faire, il ne trouve rien.

J'avoue de pas comprendre d'ou cela pourrait venir, peut-etre ma configuration doas, mais je me suis base sur la documentation et elle semble tout a fait correcte pour mes activites.

le 21/12/2017 à 20:31:05, thuban a dit :

@NewBSD : aaaah, j'ai une idée.
T'as bien installé python3 avec la lib tkinter?
Selon ta version d'OpenBSD, tu n'as peut-être pas de lien vers une version de python3 par défaut. Fais alors avant :

doas ln -s /usr/local/bin/python3.X /usr/local/bin/python3    # .X à remplacer par ta version de python 3 installée 

Sinon, lance-le directement ainsi, mais c'est plus embêtant :

doas python3.X ./owi

le 21/12/2017 à 20:58:56, NewBSD a dit :

Bingo!

J'utilisais et continurai a utiliser python2.7 par defaut, je me sens un peu c** pour le coup :)

Merci encore et super boulot !