Rendez-vous sur Arrakis

C'est lorsque nous croyons savoir quelque chose qu'il faut justement réfléchir un peu plus profondément. F. Herbert

Firefox 57 sur OpenBSD

Pour les curieux qui voudraient tester le génialissime Firefox 57 sur OpenBSD, c'est possible. Un package est actuellement disponible pour test. Vous pouvez l'installer en allant le chercher directement sur https://packages.rhaalovely.net , il faut seulement désactiver la signature du paquet :

doas pkg_add -Dunsigned https://packages.rhaalovely.net/pub/OpenBSD/snapshots/packages/amd64/firefox-57.0beta4.tgz

Et voilà :

firefox 57 sous OpenBSD

N'hésitez pas à rapporter d'éventuels bugs au créateur du paquet, ce dernier parle français : Landry Breuil : landry@openbsd.org

Edit : on me dit que c'est mal de faire ainsi. J'estime que pour un test ponctuel ça suffit. Mais l'idéal serait de copier la clé de Landry dans /etc/signify et utiliser pkg_add sans l'option -Dunsignify. Il faut tout de même avoir confiance sur le fait que la clé n'a pas été modifiée par un éventuel "pirate" (si quelqu'un est capable de remplacer le paquet de Landry par un autre, alors il peut aussi remplacer la clé)...
Cela donne donc :

doas ftp -o /etc/signify/landry-mozilla-pkg.pub https://packages.rhaalovely.net/landry-mozilla-pkg.pubPKG_PATH="https://packages.rhaalovely.net/pub/OpenBSD/snapshots/packages/amd64/" doas pkg_add firefox

Voir ici : http://undeadly.org/cgi?action=article&sid=20170425173917

le 03/10/2017 à 20:42:58, arno a dit :

Salut Thuban !
Moi je tourne toujours avec un vieux Iceweasel 38.8 !!! en quoi est-il génial ce firefox ?

le 03/10/2017 à 21:10:46, 0p3nBSD a dit :

Il est nettement plus rapide et plus optimisé que la version 38.
Mais attention à tes extensions qui ne seront sûrement pas toutes compatibles.

le 04/10/2017 à 09:39:03, spartiate a dit :

@ttention sur le lien thubans, la "," fait tâche ;)

le 04/10/2017 à 09:46:58, thuban a dit :

Ah flute, merci j'ai corrigé.

le 04/10/2017 à 10:53:52, PengouinPdt a dit :

Intéressant ! :D

Mais... attention : cette version est pour fonctionner sur un snapshot - instantané - une version actuelle de la -current, ne pas utiliser sur la -release, ou la -stable !

À contrario, ceux qui veulent utiliser/tester la dernière version de firefox, mise-à-jour v56.0, sur la -release, voire la -stable, devrait pouvoir le faire toujours à partir de ce même dépôt - inofficiel - :
https://packages.rhaalovely.net/6.1/amd64/

@thuban: merci d'avoir trouvé l'info et de l'avoir relayé ;)

le 04/10/2017 à 20:35:53, olivier a dit :

À l'EuroBSD 2017, il a d'ailleurs fait une présentation sur son implication dans la maintenance de toute la « pile Mozilla », https://www.youtube.com/watch?v=0aQQE1URHBM