Rendez-vous sur Arrakis

Publication d'isotop-0.2

C'est avec joie que je vous annonce la publication d'isotop en version 0.2.

Pour rappel, il s'agit d'une non-distribution dont l'objectif est faciliter la découverte et la prise en main d'OpenBSD. En effet, ce système peut tout aussi bien servir en “desktop” qu'en serveur. Isotop n'est finalement qu'une OpenBSD pré-configurée.

Cette nouvelle version apporte quelques changements faits par les 3hg :

Malgré les nombreux tests (merci Starsheep), il peut rester des soucis qu'il ne faut pas hésiter à rapporter. Une OpenBSD personnalisée, c'est peu fréquent et j'ai pu laisser passer des boulettes.

Tous les détails (téléchargement, installation) sont disponibles sur la page du projet. N'hésitez plus, tentez le coup ;)

le 20/10/2017 à 07:59:44, spartiate a dit :

Merci pour cet excellent travail!!

Globalement, on peut se dire qu'une fois installé via cet Iso, OpenBSD est prêt à l'emploi, rien d'autres à faire que d'ajouter des applis/configurer selon ses besoins?

le 20/10/2017 à 08:32:28, thuban a dit :

@spartiate : C'est l'objectif oui :)
ne pas oublier quand même que ce n'est qu'une 0.2, des progrès restent à faire.

le 20/10/2017 à 09:45:05, spartiate a dit :

@thuban :

Justement, est-ce que ces progrès restant à faire sont “à la charge” de l'utilisateur ? ou parle t-on de progrès au niveau de l'installateur ou de “bricoles” :)

Mon objectif est de parler largement de cet iso à mon entourage, je voudrais qu'ils aient en tête qu'une fois installé, “it’s rock” ;)

le 20/10/2017 à 11:48:42, tipiak a dit :

Pour ma part, c'est un échec !:
1)
The address wasn’t understood

Firefox doesn’t know how to open this address, because one of the following protocols (magnet) isn’t associated with any program or is not allowed in this context.

You might need to install other software to open this address.

2)
404 Not Found
OpenBSD httpd

Peut-être des précisions ?.

le 20/10/2017 à 12:39:29, Starsheep a dit :

Bonjour tipiak,

Si tu ne dis pas sur quels liens tu as cliqué pour arriver à ces erreurs, il va être difficile de t'aider.

Pour le (1), tu as dû cliquer sur un lien magnet et il est normal que Firefox ne le reconnaisse pas. Il faut copier le lien dans un logiciel de partage pair à pair (comme transmission) pour commencer le téléchargement.

le 20/10/2017 à 12:51:46, Starsheep a dit :

@tipiak : J'ai trouvé pour l'erreur 404 aussi. Dans l'url des torrents, il y a deux fois le dossier torrents : https://3hg.fr/isotop/torrents/torrents/isotop-0.2-amd64-full.iso.torrent
Tu peux essayer avec un seul et ça devrait fonctionner, en attendant la mise à jour du site…

le 20/10/2017 à 14:23:32, coyotus a dit :

J'aimerais une version openbox crunchbang like :p

le 20/10/2017 à 15:34:11, jean-cloud a dit :

Bonne initiative, merci les gars !

le 20/10/2017 à 17:22:17, thuban a dit :

@spartiate : Quand j'évoque des progrès, c'est pour les prochaines versions d'isotop. J'ai quelques idées d'amélioration (traductions, installation d'imprimante facilitée, gestion des paquets…). C'est déjà plus facile à prendre en main et ça montre qu'on peut avoir une station de travail avec OpenBSD (et tous les avantages point de vue sécurité et stabilité que ça entraîne).

@tipiak : C'est étonnant que les liens magnets ne soient pas davantage reconnus, depuis le temps que ça existe…
Désolé pour les liens torrents, c'est corrigé.

@Starsheep : Normalement les magnets sont associés directement à client torrent (mais il doit être installé…)

@coyotus : Ça roule, j'attends ton mail avec l'archive de la session Openbsd pour l'intégrer ;P

@jean-cloud : Avec plaisir :)

le 20/10/2017 à 21:06:13, coyotus a dit :

@thuban : J'ai pas trop compris, il faut mettre quoi dans l'archive ? tout la session entière ? ça fera un peu lourd comme archive ?

le 20/10/2017 à 22:31:18, Sylvain a dit :

Merci pour l'initiative, il faudra que je teste cela bientôt !

Une idée de la configuration requise ?

le 20/10/2017 à 22:46:26, kobol a dit :

@Sylvain :

un cerveau, 2 mains, une chaise, une table

le 21/10/2017 à 08:35:46, thuban a dit :

@coyotus : Je te taquine :) sinon, le dossier ~/.config/openbox sera un bon début ;)

@Sylvain : Je n'ai pas fait de benchmarks poussés. C'est une simple OpenBSD avec XFCE, la configuration requise est très modeste (très! ).

le 21/10/2017 à 23:54:43, Truc de Fortunio a dit :

Je viens de tester avec un grand bonheur sur un portable Asus, à part 2 ou 3 problèmes pour le moments :
- la mise a jour du système ne marche pas, le message me dit de lancer syspatch manuellement, ce que j'ai tenté mais sans résultat…
- firefox ne peut pas se lancer en simple utilisateur “access was denied while trying to open files in your profile directory”
De plus, j'ai eu un problème avec la configuration du wifi : le nom du réseau comporte un espace, ce qui pose problème, problème résolu en éditant à la main le hostname de ma carte et en ajoutant des guillements.
J'attends avec impatience la suite. Bravo et merci à vous.

le 22/10/2017 à 08:16:43, thuban a dit :

@Truc de Fortunio : Merci pour ce retour.
- Concernant la mise à jour, syspatch est lancé aussi par openup, qui pour l'instant ne propose pas de mises à jour (d'où le warning). C'est normal, ça va venir, OpenBSD6.2 est publiée depuis peu.
- Pour firefox, je n'ai jamais vu ce problème oO, si tu pouvais détailler car là, je ne sais pas reproduire le bug :/
- Oh, bien noté pour le nom du réseau, je vais y remédier.

le 22/10/2017 à 09:37:43, Truc de Fortunio a dit :

Merci pour les réponses. Pour Firefox, curieusement, lorsque que je l'ai lancé en simple utilisateur en cliquant sur l'icône dans le menu, j'ai ce message d'erreur : your firefox profile cannot be loaded. It may be missing or inaccessible.
Et quant je le lance à partir de la console, j'obtiens l'erreur j'ai écrite dans mon autre message. Je tenté de me déconnecté et reconnecté plusieurs fois mais cela à recommencé.

le 22/10/2017 à 09:43:16, Truc de Fortunio a dit :

Merci pour les réponses. Pour Firefox, curieusement, lorsque que je l'ai lancé en simple utilisateur en cliquant sur l'icône dans le menu, j'ai ce message d'erreur : your firefox profile cannot be loaded. It may be missing or inaccessible.
Et quant je le lance à partir de la console, j'obtiens l'erreur j'ai écrite dans mon autre message. Je tenté de me déconnecté et reconnecté plusieurs fois mais cela à recommencé. Mais pas de problème avec firefox lancé en root…

le 22/10/2017 à 17:59:29, spartiate a dit :

le torrent isotop-0.2-amd64-full.fs ne démarre pas sous rtorrent, le problème ne peut provenir que de chez moi ? pas de soucis pour download d'autres torrent….

le 22/10/2017 à 18:08:50, thuban a dit :

@spartiate : ça fait combien de temps que c'est actif? Sans tracker, ça peut être long. J'ai toujours eu des soucis avec les magnets et rtorrent. Tente avec transmisson

le 22/10/2017 à 20:22:04, spartiate a dit :

Cela fonctionne en effet avec transmission…..curieux qu'avec rtorrent ça démarre pas, le tout étant de l'a récupérer cette iso :)

le 22/10/2017 à 20:25:43, kobol a dit :

Thuban as tu reçu mon mail pour la suppression ?.

le 22/10/2017 à 21:42:04, thuban a dit :

@Truc de Fortunio : ne pas lancer en root voyons. Supprime le dossier .mozilla et copie celui situé dans /etc/skel à la place.

@spartiate : Good. C'est pas les même lib de torrent. L'une est plus efficace.

@kobol : non. Suppression de quoi?

le 22/10/2017 à 22:09:51, kobol a dit :

Je t'ai envoyé un mail par le forum, pour la suppression de mon compte sur le forum.

le 23/10/2017 à 12:39:57, Truc de Fortunio a dit :

@thuban : Au temps pour moi, j'ai fini par me mélanger les pinceaux… J'ai dû lancer Firefox à partir du terminal dans lequel je venais d'installer le firmware de ma carte réseau.
En parlant de terminal :
- le prompt de ksh dans le terminal de xfce demeure chez moi minimaliste malgré le .kshrc, sans $PWD…
- dans la console (sans X), les accents ne sont pas pris en compte. Peut-on y faire qualque chose ?

le 23/10/2017 à 12:42:23, thuban a dit :

@Truc de Fortunio : Je n'ai pas modifié le prompt ksh par défaut, à chacun de faire celui qu'il aime :)

Pour la console j'ai bien les accents. C'est peut-être avec certains logiciels comme vi que tu ne les as pas ?

le 23/10/2017 à 12:58:29, Truc de Fortunio a dit :

@thuban : OK, je pensais que le terminal de xfce prenait en compte le .kshrc présent par défaut dans mon home. Dans ce .kshrc, il y a bien PS1=‘<$LOGNAME@$HOSTNAME:/${PWD#/}> ’ pourtant…

Pour les accents, je parle de TTYC1 et les autres. J'aime bien travailler dans ces terminaux en plein écran…

le 23/10/2017 à 13:28:35, Truc de Fortunio a dit :

@Truc de Fortunio : Je me réponds (désolé, j'aurais dû chercher un peu plus…) : pour avoir la prise en compte de .kshrc dans le terminal de xfce, j'ai rajouté dans mon .profile : “export ENV=$HOME/.kshrc”. Peut-être que pour un OpenBSD destiné à des noobs comme moi, ce pourait être un petit truc à ajouter…

le 23/10/2017 à 20:36:53, anatolem a dit :

Il m'aura fallu 3 essais d'installation pour avoir un système opérationnel, sauf LibreOffice qui ne voulait pas se lancer, j'ai désinstaller et à la nouvelle re-installation c'était OK.
N'ayant aucune connaissance en OpenBsd je patauge mais je trouve le poisson sympa.
A pluche.

le 24/10/2017 à 14:28:52, thuban a dit :

@Truc de Fortunio : C'est une excellent suggestion pour le ksh. Pour les accents, ils sont supportés normalement.

@anatolem : Pourquoi 3 essais?
Content que ça t'aie donné envie d'essayer :)

le 24/10/2017 à 18:07:18, anatolem a dit :

@thuban : Bin, je ne sais pas à chaque fois je suis bien arrivé à faire l'installation jusqu'au moment du reboot mais ensuite j'arrivais sur un truc tout moche gris, sans menu, certainement une erreur de ma part, mais comme je suis curieux j'ai re-tenté jusqu'à ce que j'arrive. Mais libreOffice voulait pas démarrer.
Je suis curieux mais pas encore prêt à passer sous OpenBsd :D
A pluche.

le 24/10/2017 à 21:07:35, colleen a dit :

un petit mot sur mon utilisation d'isotop 0.2 : pas de méchants bugs rencontrés pour l'instant, tout fonctionne \0/ :)
sauf que ma carte wifi n'est pas reconnue sur mon vieux thinkpad lenovo l512, tant pis.
merci beaucoup thuban de permettre aux gens d'appréhender ce système en douceur.
merci aussi à ceux qui gèrent le wiki, notamment pengouinBSD.
je me permets 2 questions de noob en passant :
- quelle est la commande qui permet de savoir sous quelle saveur on est ? j'ai tenté un uname -a mais ça me l'indique pas.
- y a t il un moyen d'enlever proprement une clé usb ou de le faire à l'arrache c'est pas un souci ?

le 24/10/2017 à 23:17:17, thuban a dit :

@colleen : Pour le wifi, c'est étonnant vu le modèle. Il faudrait creuser cette histoire. Tu as un accès en ethernet pour récupérer les firmwares avec la commande “fw_update” ?

- Pour connaître la saveur, uname -a peut faire l'affaire. Je vois pour ma part que je suis en 6.2 et pas -current (donc je suis en stable). Sinon, ‘uname -r’ suffit :)
- Normalement, une clé USB se démonte avec “umount”, tu as raison. Sauf que j'ai mis le démon hotplugd dans isotop, si bien que lorsqu'on débranche une clé, elle est automatiquement démontée ;)

le 27/10/2017 à 14:10:35, Starsheep a dit :

@anatolem : Tu avais bien coché le set “site62.tgz” à l'installation ? Le fait d'avoir un Xfce tout gris peut venir de là.

le 28/10/2017 à 17:59:39, anatolem a dit :

@Starsheep : Oui, j'avais mis “all” pour avoir tout mais peut-être que “tout” n'a pas été sélectionné. Pourquoi le set “site62.tgz” n'est pas sélectionné d'office ?
A pluche.

le 28/10/2017 à 18:59:59, thuban a dit :

@anatolem : Il n'est pas sélectionné d'office car ce n'est pas possible sans modifier le code source de l'installateur d'OpenBSD, ce que je ne souhaite pas :)

le 28/10/2017 à 20:52:20, kobol a dit :

Question a 100 balles, quand on a un serveur dédié, un site openbsd, un mirroir openbsd. Pourquoi, ne pas faire un rajout de dossier “Isotop” sur ce mirroir pour le DL ?.

Puisque là, en 3 jours. Aucune connexion, en netinstall amd64… .

On passe de Openbsd a ClosBSD ^^.

le 28/10/2017 à 21:39:39, thuban a dit :

@kobol : Réponse gratuite, pourquoi ne pas utiliser un client torrent qui supporte le DHT et les liens magnets, depuis le temps que ça existe?

le 28/10/2017 à 22:05:39, kobol a dit :

réponse à la réponse idiote :), sans faire de jeux de mots “transmission” de reçoit rien.

Reçu 5/5 Alpha, tango, charlie ?.