Rendez-vous sur Arrakis

C'est lorsque nous croyons savoir quelque chose qu'il faut justement réfléchir un peu plus profondément. F. Herbert

Publication d'isotop-0.2.1

Première mise à jour pour isotop, l'OpenBSD personnalisée et préparée pour une utilisation bureau.

Parmi les changements effectués, vous remarquerez que :

Tous les liens sont sur la page officielle, je recopie ici uniquement les magnets à ouvrir avec un client bittorrent (avec trackers publics)

magnet:?xt=urn:btih:45e36d480c6e813e822fbd36f454799a0bde686d&dn=isotop-0.2.1-amd64-full.fs.xz&tr=udp%3A%2F%2Ftracker.openbittorrent.com%3A80&tr=udp%3A%2F%2Ftracker.opentrackr.org%3A1337&tr=udp%3A%2F%2Ftracker.coppersurfer.tk%3A6969&tr=udp%3A%2F%2Ftracker.publicbt.com%3A80&tr=http%3A%2F%2Fopensharing.org%3A2710%2Fannounce&tr=udp%3A%2F%2Ftracker.leechers-paradise.org%3A6969&tr=udp%3A%2F%2Fzer0day.ch%3A1337
 
 magnet:?xt=urn:btih:8d86b6c82bec186da5ce800c6497ec04d9d42f59&dn=isotop-0.2.1-amd64-full.iso.xz&tr=udp%3A%2F%2Ftracker.openbittorrent.com%3A80&tr=udp%3A%2F%2Ftracker.opentrackr.org%3A1337&tr=udp%3A%2F%2Ftracker.coppersurfer.tk%3A6969&tr=udp%3A%2F%2Ftracker.publicbt.com%3A80&tr=http%3A%2F%2Fopensharing.org%3A2710%2Fannounce&tr=udp%3A%2F%2Ftracker.leechers-paradise.org%3A6969&tr=udp%3A%2F%2Fzer0day.ch%3A1337
 
 magnet:?xt=urn:btih:6523d3c7a9923ec0b78d12501afffe05c6960e95&dn=isotop-0.2.1-amd64-netinst.fs.xz&tr=udp%3A%2F%2Ftracker.openbittorrent.com%3A80&tr=udp%3A%2F%2Ftracker.opentrackr.org%3A1337&tr=udp%3A%2F%2Ftracker.coppersurfer.tk%3A6969&tr=udp%3A%2F%2Ftracker.publicbt.com%3A80&tr=http%3A%2F%2Fopensharing.org%3A2710%2Fannounce&tr=udp%3A%2F%2Ftracker.leechers-paradise.org%3A6969&tr=udp%3A%2F%2Fzer0day.ch%3A1337
 
 magnet:?xt=urn:btih:81d3582a2988699746ea896b96b2a596d99ddb08&dn=isotop-0.2.1-amd64-netinst.iso.xz&tr=udp%3A%2F%2Ftracker.openbittorrent.com%3A80&tr=udp%3A%2F%2Ftracker.opentrackr.org%3A1337&tr=udp%3A%2F%2Ftracker.coppersurfer.tk%3A6969&tr=udp%3A%2F%2Ftracker.publicbt.com%3A80&tr=http%3A%2F%2Fopensharing.org%3A2710%2Fannounce&tr=udp%3A%2F%2Ftracker.leechers-paradise.org%3A6969&tr=udp%3A%2F%2Fzer0day.ch%3A1337
 
 magnet:?xt=urn:btih:42f765c3d53ee04b2a85b694fa9b0a5994885d91&dn=isotop-0.2.1-i386-full.fs.xz&tr=udp%3A%2F%2Ftracker.openbittorrent.com%3A80&tr=udp%3A%2F%2Ftracker.opentrackr.org%3A1337&tr=udp%3A%2F%2Ftracker.coppersurfer.tk%3A6969&tr=udp%3A%2F%2Ftracker.publicbt.com%3A80&tr=http%3A%2F%2Fopensharing.org%3A2710%2Fannounce&tr=udp%3A%2F%2Ftracker.leechers-paradise.org%3A6969&tr=udp%3A%2F%2Fzer0day.ch%3A1337
 
 magnet:?xt=urn:btih:f28fad02eb0bcf4d155930f6374243674c857418&dn=isotop-0.2.1-i386-full.iso.xz&tr=udp%3A%2F%2Ftracker.openbittorrent.com%3A80&tr=udp%3A%2F%2Ftracker.opentrackr.org%3A1337&tr=udp%3A%2F%2Ftracker.coppersurfer.tk%3A6969&tr=udp%3A%2F%2Ftracker.publicbt.com%3A80&tr=http%3A%2F%2Fopensharing.org%3A2710%2Fannounce&tr=udp%3A%2F%2Ftracker.leechers-paradise.org%3A6969&tr=udp%3A%2F%2Fzer0day.ch%3A1337
 
 magnet:?xt=urn:btih:27c53186b29bd785ebbf6ff48563191f2a2014a9&dn=isotop-0.2.1-i386-netinst.fs.xz&tr=udp%3A%2F%2Ftracker.openbittorrent.com%3A80&tr=udp%3A%2F%2Ftracker.opentrackr.org%3A1337&tr=udp%3A%2F%2Ftracker.coppersurfer.tk%3A6969&tr=udp%3A%2F%2Ftracker.publicbt.com%3A80&tr=http%3A%2F%2Fopensharing.org%3A2710%2Fannounce&tr=udp%3A%2F%2Ftracker.leechers-paradise.org%3A6969&tr=udp%3A%2F%2Fzer0day.ch%3A1337
 
 magnet:?xt=urn:btih:fc9fc6b8f57cf9773071eb8deda187eb59cdbd8d&dn=isotop-0.2.1-i386-netinst.iso.xz&tr=udp%3A%2F%2Ftracker.openbittorrent.com%3A80&tr=udp%3A%2F%2Ftracker.opentrackr.org%3A1337&tr=udp%3A%2F%2Ftracker.coppersurfer.tk%3A6969&tr=udp%3A%2F%2Ftracker.publicbt.com%3A80&tr=http%3A%2F%2Fopensharing.org%3A2710%2Fannounce&tr=udp%3A%2F%2Ftracker.leechers-paradise.org%3A6969&tr=udp%3A%2F%2Fzer0day.ch%3A1337
 

Pour finir, je laisse ici une petite vidéo d'une installation filmée, en 15 minutes 34 secondes chrono, pour fred' ;)

le 30/10/2017 à 13:06:01, Frederic Bezies a dit :

Oh, petit canaillou, une vidéo pour montrer l'installation… :)

Sinon, rien que le changelog, ça donne envie de faire mumuse avec… Miam :)

Je vais en parler dans la semaine :)

le 30/10/2017 à 13:07:10, thuban a dit :

@Frederic Bezies : Hi hi hi, j'ai pas résisté ;) Promis je n'ai pas triché, ce n'est pas accéléré.
N'hésite pas à rapporter les bugs que tu trouveras ;)

le 30/10/2017 à 14:08:06, l'@nar Geek a dit :

Coucou,
ça semble chouette comme nouvelle version :)) c'est tout beau ^^

Par contre j'ai quelques problèmes qui persistent pour télécharger les .fs et les .iso en torrent, ça ne marche pas avec Tranmission, ni avec Bittornado sur mon pc mais aucun problème sur Android avec LibreTorrent.

le 30/10/2017 à 14:08:57, thuban a dit :

@l'@nar Geek : Tu n'aurais pas blindé ton parefeu toi par hasard? ;P

le 30/10/2017 à 16:46:06, l'@nar Geek a dit :

@thuban le pare feu est désactivé :D Transmission dit que le torrent est introuvale à chaque fois que j'essaie.

Mon réseau fait des trucs bizarres en ce moment, privoxy s'est cassé la gueule, et la connexion internet se coupe toute seule; ça vient peut être de ça.

le 30/10/2017 à 18:46:33, DrWhoWatchYou a dit :

salut :)
très chouette, merci pour cette OBSD très sympa
je l'installe ce soir pour test en dur, je suppose que ça ne pose pas de soucis si j'utilise la 0.2?
bonne soirée

le 30/10/2017 à 20:54:00, kobol a dit :

JE L AI !!!!!, CA MARCHE !!!!!.

Pour info, seulement 3 trackers sur les 7 fonctionnent.

udp://tracker.opentrackr.org:1337

udp://tracker.coppersurfer.tk:6969

udp://tracker.leechers-paradise.org:6969

le 30/10/2017 à 23:43:27, kobol a dit :

Comme thuban, c'est bien rattrapé sur cette affaire !. Voici un ptit lien qui devrait le faire rire. (récompense)

http://www.undeadly.org/cgi?action=article;sid=20171015115539

un extrait traduit (ci-dessous):

Le commentaire ci-dessus est ce qui se passe quand, métaphoriquement parlant, une personne intelligente est atteinte d'un cancer du cerveau. Certaines personnes devraient être plus paranoïaques au sujet de leur confiance centrée sur elles-mêmes et de ce que cela peut faire à leur image lorsqu'elles partagent de telles idées avec un niveau de confiance aussi fort et insultant. D'autres personnes devraient afficher en utilisant leur vrai nom complet juste pour être associé à la guérison pour un tel cancer. Merci mon pote,

Ah ces geeks, geek un jour, geek toujours. Rock n'roll !

le 31/10/2017 à 17:04:20, DrWhoWatchYou a dit :

petit retour rapide sur l'install en dure:
-je n'ai pas de son (testé sous firefox, mais aussi deadbeef et mplayer : c'est comme si aucun player ne démarrait, même quand les miniature s'affiche)
-Tor se lance puis plante aussitôt
-la clé usb est bien monté quand je la branche, mais j'ai du aller voir “à la main” (dans/mnt) pour la trouver

le 31/10/2017 à 17:32:50, DrWhoWatchYou a dit :

ps : et pour quitter, je n'ai que le bouton de déconnection (les autres sont grisés)

le 31/10/2017 à 18:25:38, thuban a dit :

@DrWhoWatchYou : Ce serait bien de lancer les programmes en console, pour afficher un retour des erreurs affichées.

- Le son : as-tu tenté de régler le volume ?
- Tor n'est pas installé, c'est le torbrowser. Quel retour est affiché?
- La clé USB, il n'y a pas de notifications, mais c'est écrit sur la page d'isotop que c'est monté dans /mnt .
- C'est pour quel utilisateur? Celui par défaut? Un autre installé? Tu as redémarré ?

le 31/10/2017 à 20:45:13, DrWhoWatchYou a dit :

ok, reboot, session user:
-les boutons d'arrêt sont tous là :)
-tor-browser fonctionne au tout début, puis plante sur ces erreurs:

[Child 34847] ###!!! ABORT: Aborting on channel error.: file /usr/obj/ports/tb-browser-7.0.5/torb-7.0.5-esr52.3.0/ipc/glue/MessageChannel.cpp, line 2152
 [Child 34847] ###!!! ABORT: Aborting on channel error.: file /usr/obj/ports/tb-browser-7.0.5/torb-7.0.5-esr52.3.0/ipc/glue/MessageChannel.cpp, line 2152
 Oct 31 21:32:17.000 [notice] Catching signal TERM, exiting cleanly.
 Segmentation fault (core dumped)



pour le son, non, je n'ai rien modifié
ma carte son est reconnu par le système (je vois son nom au boot), mais je ne sais pas si c'est normal qu'elle s'affiche comme Unknow (OSS Mixer) dans la config du son xfce

pour les players, tous sont figés (y compris celui de youtube)

le 08/11/2017 à 14:11:01, anatolem a dit :

J'ai installé cette nouvelle mouture (virtualbox) sans problème, et j'ai aussi “parfois” les icônes déconnexion grisés (non opérationnel) mais le plus ennuyeux c'est le son comme “DrWhoWatchYou”, le son est en accéléré dans les vidéos sur youtube et la carte son s'affiche comme “unknow (oss mixer).
Je mets cela sur le compte de la machine virtuel ?

le 08/11/2017 à 14:25:55, thuban a dit :

@anatolem : Très certainement, la gestion mémoire et le support d'OpenBSD sous virtualbox est vraiment limite :/
Avec qemu, ça marche mieux :)

le 08/11/2017 à 16:42:41, DrWhoWatchYou a dit :

sauf que je suis "en dur” :P
je n'ai pas poussé les tests plus avant, j'y retourne bientôt
@thuban, merci tout-de-même pour ce chouette non-OS et pour le temps que tu accordes au support quand tu peux (et/ou trouves les solutions) :)

le 08/11/2017 à 16:46:12, thuban a dit :

@DrWhoWatchYou : Alors la réponse est peut-être tout simplement qu'OpenBSD gère mal ton matériel. Pour améliorer ce point, il faut envoyer le dmesg aux développeurs grâce à l'outil intégré à isotop ;)

le 08/11/2017 à 19:18:57, DrWhoWatchYou a dit :

merci
au passage, si je change de carte son, comment ça se passe sous OBSD? le noyau est recompilé (ai lu truc dans le genre, sais plus où) automatiquement avec le pilote qui va bien?
pour le dmesg, je l'ai fait post-install via le TkMenu, mais à part la fenêtre (le TkMenu) qui se ferme de suite, je ne sais pas si le message est partit

le 08/11/2017 à 19:21:15, thuban a dit :

@DrWhoWatchYou : Si tu avais un accès à internet, ça a du partir. Je devrais ajouter un message confirmation en effet :)

le 15/11/2017 à 20:18:05, DrWhoWatchYou a dit :

install en dur, cette fois sur un laptop…
salut
hé hé, j'ai du son :)
par contre, je n'ai pas de réseau, ni wifi, ni ethernet
une question me vient : est-ce que je ne peux pas utiliser le wifi parce que j'ai le câble ethernet branché?
l'utilitaire graphique du TkMenu ne trouve aucun reseau, c'est curieux
je teste plus tard sans le câble (mais si ma carte wifi n'est pas reconnue, ça ne m'avancera pas beaucoup)

le 15/11/2017 à 20:20:16, DrWhoWatchYou a dit :

*note : l'interface de la box me dit que je me suis connecté

le 15/11/2017 à 21:04:05, thuban a dit :

@DrWhoWatchYou : Super pour le son :)
Pour le réseau, je n'avance pas que le gestionnaire WiFi owi soit parfait hein. Si ça dépanne, tant mieux, mais il faut peut-être aller plus loin pour configurer ton réseau selon si tu as du WPA ou du matériel particulier.

une question me vient : est-ce que je ne peux pas utiliser le wifi parce que j'ai le câble ethernet branché?

Owi choisira l'ethernet avant le WiFi s'il est branché oui.

Si tu as besoin d'aide pour la reconnaissance de ta carte WiFi : https://obsd4a.net/forum

le 15/11/2017 à 21:22:36, DrWhoWatchYou a dit :

merci
à choisir, je vais faire autrement : me passer du wifi
c'est ce que j'ai fait, j'ai été dans le setup du bios désactiver le wireless
ça redémarre, bien entendu j'ai le câble branché
et rien, toujours pas de réseau
petite remarque : curieux que le masque de sous-réseau soit indiqué comme de l'ipv6 (0xff…)
le reste est indiqué en ipv4 (192.168…)
sinon, avec ifconfig les status sont bien “active”

le 15/11/2017 à 21:24:24, thuban a dit :

@DrWhoWatchYou : Mais est-ce que tu as configuré l'interface filaire ? (fichier /etc/hostname.interface) Tu n'es passé que par owi ?
Si tu peux avoir de l'ipv6, alors owi l'active.
Et ce que tu cites là, c'est pas de l'ipv6 :)

le 15/11/2017 à 21:33:23, DrWhoWatchYou a dit :

non, je n'ai rien configuré, j'ai le dhcp
oui, je ne suis passé que par owi (mais sans rien pouvoir modifier)
à l'install je n'ai pas choisi l'ipv6, ça m'étonnais aussi :)
je vais tester un truc : une réinstall (mais pas vraiment, je choisirais l'option upgrade)
si ça ne change rien, je réinstalle pour de bon, cette fois avec le bios sans wireless et le rj45 uniquement

le 15/11/2017 à 21:46:35, thuban a dit :

@DrWhoWatchYou : Ça ne changera rien, l'upgrade utilise la configuration réseau du système mais ne la modifie pas (heureusement!).
J'ai peur que tu t'embêtes à vouloir réinstaller. Certes, ça marchera, mais c'est prendre un bazooka pour tuer un moustique là ;)

le 15/11/2017 à 22:25:47, DrWhoWatchYou a dit :

oui, ça me semble aussi :P
/etc/hostname.interface?
j'ai pas

le 16/11/2017 à 00:10:56, DrWhoWatchYou a dit :

tadaaa! le reseau fonctionne :)
comment j'ai fait?
ben j'ai pas fait grand-chose
j'ai (en cli) spécifié que je voulais du 255.255.255.0 en netmask
ça n'a rien changé
après reboot, ça n'a rien changé non-plus
j'ai donc rebooté avec un live-cd pour voir si j'avais du réseau
y avait
j'ai rebooté OBSD (pensant continuer de chercher) et c'est bon, j'avais du réseau
finalement, j'ai surtout redémarré plusieurs fois :)

le 16/11/2017 à 01:33:31, DrWhoWatchYou a dit :

ce qui génère un problème avec Firefox:

$ firefox
 Error: Access was denied while trying to open files in your profile directory.

ça fonctionne avec doas, mais je pense que ce n'est pas une bonne idée…
sinon, Thunderbird fonctionne, lui

le 16/11/2017 à 12:39:55, thuban a dit :

@DrWhoWatchYou : /etc/hostname.interface : il faut remplacer “interface” par ton interface (que tu trouveras avec ifconfig).

Le problème avec irefox indique que ton utilisateur n'a pas les droits d'écriture. T'as fait mumuse avec doas toi, tu l'as lancé en root, donc forcément…
Supprime le dossier .mozilla, ça ira mieux.

Si tu veux, tu trouveras des réponses plus rapides sur le forum https://obsd4a.net/forum ;)

le 16/11/2017 à 13:17:32, DrWhoWatchYou a dit :

ah oui, désolé
merci de ta patience
du coup j'y pense, puisque ça peut devenir infernal pour toi et ton blog si les gens y viennent pour le support, peut-être (?) préciser pour les prochaines moutures une phrase du genre “le support OBSD c'est pas ici mais sur OBSD4*, merci de votre compréhension”
sinon, pour doas non, je l'ai testé parce que ça ne fonctionnait pas sans
merci encore, bonne fin de semaine :)

le 16/11/2017 à 21:06:24, thuban a dit :

@DrWhoWatchYou : C'est surtout que c'est peu pratique, pas réactif pour toi :)
Je croyais avaoir mis un mot dans ce sens, j'ai peut-être zappé.

le 28/11/2017 à 00:22:01, DrWhoWatchYou a dit :

salut, toujours content d'utiliser cet os, merci pour tout
ps : le propre des vagues (parfois même “à l'âme”) c'est de remonter, courage ;)
pps : un fond d'écran qui va te plaire (je suppose) ci dessous:
https://framapic.org/afkOjnHNBS0q/WesQG7IFaxZH.jpg
ppps : et une chaîne youtube (qui n'est pas de moi) qui va te plaire aussi, lien ci-dessous:
https://www.youtube.com/channel/UC7pAlSfuvMIusHwTasEn2UA/playlists
bon visionnage, à bientôt

le 28/11/2017 à 12:31:19, thuban a dit :

@DrWhoWatchYou : Wahou, trop cool le fond d'écran. :)

le 28/11/2017 à 13:03:07, Hardcore a dit :

Rapport isotop :

Install OK

Reboot OK

Xfce absent

Appli en CLI OK

Video et son OK

Dans l'ensemble du bon boulot !. :)

J'attends la version stable !.

le 03/12/2017 à 02:20:36, DrWhoWatchYou a dit :

salut,
@thuban, cool si le fond d'écran t'a plût
ps : tite question, la prochaine version avec la possibilité de chiffrement à l'install (ou c'est pas prévu) ? :)
merci d'avance, bon we

le 03/12/2017 à 08:30:30, thuban a dit :

@DrWhoWatchYou : C'est déjà possible, en suivant les instructions de la FAQ (ou bien ça : https://yeuxdelibad.net/ah/#diskcrypt).
Cela dit, le faire de façon automatisée c'est pas évident, il faudra que j'y réfléchisse soigneusement.

le 12/03/2018 à 11:33:07, pololasi a dit :

Bonjour

Quel est la place minimum requise sur le disque dur pour installer isotop ?
J'ai tenté l'installation sur un vieux netbook avec un ssd de 16 go et après le reboot ça coince pour l'installation des paquets au bout d'un moment, un message me prévient que je n'ai plus assez de place sur le disque dur.
Et en continuant tout de même je ne peux pas connecter l'utilisateur je reviens a chaque tentative sur la fenêtre d'authentification sans message d'erreur.
Il semble qu'il manque dans l'installation des utilitaires de xfce servant pour l'authentification de l'utilisateur. Par contre je peux me connecter en root et j'ai juste accès a xterm.

le 12/03/2018 à 11:50:48, thuban a dit :

@pololasi : 16G ça passe normalement, mais il faut modifier le partitionnement automatique proposé par l'installateur OpenBSD pour n'avoir qu'une partition “/”

le 12/03/2018 à 12:30:23, pololasi a dit :

@thuban : Merci
Je suppose que ça se change a l’étape du partitionnement et qu'il faut entrer e pour éditer le partitionnement proposé à la base mais j'ai eu beau regarder avec h pour help je ne comprends pas comment faire.

le 12/03/2018 à 12:53:16, thuban a dit :

@pololasi : oui c'est à l'étape du partitionnement, avec disklabel, il faut éditer l'autoconfiguration proposée.
C'est moins compliqué que ça en a l'air :
- p : affiche le partitionnement
- a <lettre> : ajoute un morceau
- d <lettre> : supprime un morceau
- q : quitte et sauvegarde.

Voir là : https://yeuxdelibad.net/ah/#install

le 12/03/2018 à 13:11:18, pololasi a dit :

@thuban :
Ok je vais supprimer toutes les partitions et recréer la a avec un a a et ensuite demander le point de montage a / et un q pour sauvegarder et quitter